New member and new R1900 owner

Epson's eagerly awaited printer

Moderators: gcrogers, Kevgermany, Costas L

New member and new R1900 owner

Postby Doug Kerr » Tue Feb 03, 2009 10:05 pm

Greetings,

I just joined the forum (largely because I heard from Oz that this was a good place to discuss the Epson Stylus Color R1900, and so it seems).

By way of introduction, I am a retired telecom engineer, and I fiddle around with digital photography. My colleagues say I am much more a camera engineer than a photographer, and it's true!

You can find some of my writings here:

http://doug.kerr.home.att.net/pumpkin/index.htm

I've been using an Epson Stylus Photo R800 for several years, and have been generally pleased. But I am beset by nozzle clogs, and the problem seems to be getting worse.

So, deciding to take the direct approach, I ordered an R1900 from B&H Photo-Video in New York. It should arrive Friday, 2009.02.05.

I downloaded the latest driver package from Epson and installed it. (I wanted to see what goodies were on the control panel!) When the machine comes, I will probably decline to install all the Epson stuff. If somebody tells me I should go back to the "out-of-the-box" drivers, I will see if I can install them without all the stuff.

In any case, I see in various reviews of this machine comments about the Photo RPM mode. I don't see that as a choice on any driver control panel. Is that just the actual technical name for the Best Photo mode, or what?

Thanks.

Best regards,

Doug
Doug Kerr
 
Posts: 18
Joined: Tue Feb 03, 2009 9:10 pm
Location: Weatherford, Texas (North Texas), USA

Re: New member and new R1900 owner

Postby Costas L » Tue Feb 03, 2009 11:09 pm

Welcome to the forum Doug

to see the Photo RPM setting, you have to select a glossy paper (or semi-gloss), does not work with matte
Costas
"How could I have been so mistaken as to trust the experts" John F Kennedy 1962
Costas L
Site Admin
 
Posts: 3115
Joined: Sat Feb 26, 2005 10:55 am
Location: UK

Re: New member and new R1900 owner

Postby Doug Kerr » Tue Feb 03, 2009 11:28 pm

Hi, Costas,

Costas L wrote:to see the Photo RPM setting, you have to select a glossy paper (or semi-gloss), does not work with matte

I had been looking for it among the modes on the Main tab, not in the drop-down on the Advanced tab.

Thanks.

Best regards,

Doug
Doug Kerr
 
Posts: 18
Joined: Tue Feb 03, 2009 9:10 pm
Location: Weatherford, Texas (North Texas), USA

Re: New member and new R1900 owner

Postby ainsley » Mon Jan 06, 2014 10:28 am

I haven't kept up with your posts so I don't know your experience level. If you are relatively new to photo printing, a good start for gloss might be Epson Premium Glossy. I used a lot of it with my R1800 and loved the results (with the GLOP). Actually, for pure gloss that's all I ever used. You could always try different brands later.
I am especially grateful for having all this Level free braindumps 200-120 you can find us on IBM
you can also find us on Youtube
ainsley
 
Posts: 1
Joined: Mon Jan 06, 2014 10:24 am


Return to Epson R1900

Who is online

Users browsing this forum: No registered users and 1 guest

cron